
McIDAS-V Tutorial 
Using and Creating Formulas 

updated June 2012 (software version 1.2) 
 

 
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 
SSEC's 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 
manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 
Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands 
and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being 
integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data. 
 
More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-
V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at the startup of 
McIDAS-V when new versions are available on the McIDAS-V webpage - 
http://www.ssec.wisc.edu/mcidas/software/v/ .  
 
If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums 
- http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other 
users. 
 
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 
McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the 
document entitled McIDAS-V Tutorial – Installation and Introduction.   
 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 
Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 
Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 
Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit ->Remove ->All Layers and Data Sources). 
 
Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).   

 
 
Introduction 
 
There are three methods of using formulas in McIDAS-V:  system formulas which are provided as part of the 
McIDAS-V software, user-defined formulas which can be created and executed from within McIDAS-V, and 
user-defined formulas which can be defined in jython code written by the user.  This tutorial will cover the first 
two categories, those that can be created and used within McIDAS-V. 
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System Formulas – Simple Subtraction 
 
1. Load the forecast data for Super Typhoon Megi. 

 
a. In the Data Sources tab of the Data Explorer, open the Gridded Data tree and select Local. 

 
b. Under Look in, individually add data sources for the following files: 

 
<local path>/formulas/TyphoonMegi/gfs_4_20101017_0000_000.grb2 
<local path>/formulas/TyphoonMegi/gfs_4_20101017_0000_024.grb2 
 

2. Create a Simple Difference formula, subtracting the 0 hour forecast from the 24 hour forecast Pressures. 
 
a. In the Field Selector tab, select Formulas under Data Sources. 

 
b. Under Fields, open the Miscellaneous tree and select Simple difference a-b. 

 
c. Under Displays, open the Imagery tree and select Image Display. 

 
d. Click Create Display. 

 
e. In the new Field Selector window, select: 

 
i. For Field: a, open and select the gfs_4_20101017_0000_024.grb2 -> 2D grid -> Mass -> 

Pressure_reduced_to_MSL @ msl 
 

ii. For Field: b, open and select the gfs_4_20101017_0000_000.grb2 -> 2D grid -> Mass -> 
Pressure_reduced_to_MSL @ msl 
 

f. Click OK to display the results of the Simple difference a-b. 
 

g. Zoom into the Philippines area. The darker region southeast of the whiter region shows areas where 
pressure drops are forecasted.  Drawing a line between the whiter and darker regions gives an indication 
of the predicted storm motion.  
 
 

System Formulas – Combining Multiple Formulas 
 
3. Remove All Layers via the Edit -> Remove ->All Layers menu item in the Main Display. 

 
4. Add the forecast verification file for the 24 hour forecast: 

 
a. In the Data Sources tab, open the Gridded Data tree and select Local. 

 
b. Add a data source for the file <local path>/formulas/TyphoonMegi/gfs_4_20101018_0000_000.grb2 
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5. Create a Simple Difference formula, subtracting the verification grid (Oct 18 – 0Z, 0 hr) from the forecast 
grid (Oct 17 – 0Z, 24 hr).  
 
a. In the Field Selector, under Data Sources, select Formulas.  Under Fields, open the Miscellaneous 

tree and select Any Field.  Under Displays, open the 3D Surface tree and select Topography. 
 

b. Click Create Display. 
 

c. Using the new Field Selector window, select Formulas ->Miscellaneous -> Simple difference a-b. 
 

d. Click OK. 
 

e. For field a, select gfs_4_20101017_0000_024.grb2 -> 3D -> Mass -> Geopotential_height@pressure 
 

f. Click the Level tab and select 100,000 Pa. 
 

g. For field b, select gfs_4_20101018_0000_000.grb2 -> 3D -> Mass -> Geopotential_height@pressure 
 

h. Click the Level tab and select 100,000 Pa. 
 

i. Click OK.    The display will use the (Verification Grid – Forecast Grid) equation for model 
verification. 
 

6. Change the range of the color table to enhance features on the display. 
 

a. From the Legend in the Main Display, right click on the color bar and select Change Range… 
 

b. In the From: text box, enter -200, in the To: text box enter 200.  Click OK. 
 

7. The display now showing is a 2-dimensional display of the (Verification Grid – 
Forecast Grid) results.  However, recall that when the image was displayed, it was 
displayed as a 3D Topography surface.  By default, the vertical range of McIDAS-V 
displays is 0-16,000 m.  To view the data as topography, the vertical range will have 
to be changed to more closely match the range of the data.  In this example, change 
the vertical range  to -100 to 100 m. 

 
a. From the tool icons on the left side of the Main Display window, click the Set the 

vertical scale icon (shown in the figure to the right). 
 

b. Change the Min Value to -100, Max Value to 100 and Units to m.  Click OK. 
 

8. Sometimes when viewing 3-Dimensional data, the map becomes obscured by the data.  If the map is hidden, 
move the Map layer up, so it is visible on the image. 
 
a. From the Legend, click Default Background Maps. 

 
b. In the Layer Controls tab, select the Settings tab. 

 
c. Slide the Map Position value to 0.3. 
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System Formulas – Creating a Water Vapor Sea Surface Temperature Display 
 
9. Remove All Layers and Data Sources via the Edit -> Remove -> All Layers and Data Sources menu in the 

Main Display. 
 

10. Create local datasets for global SST, water vapor, IR, and land/sea mask images: 
 

a. From the Main Display menu, select Tools -> Manage ADDE Datasets. 
 

b. Select File -> New Local Dataset. 
 

c. For Dataset, enter GLOBAL.  For Image Type, enter SST. 
 

d. Click the Browse button, choose <local path>/formulas/sea-surface-temperature, and click Open. 
 

e. Click Add Dataset. 
 

f. For Dataset, enter GLOBAL.  For Image Type, enter WV.  Browse to  
<local path>/formulas/global-wv, and click Open.  Add Dataset. 
 

g. Repeat for IR.  (GLOBAL, IR, <local path>/formulas/global-ir).  Open.  Add Dataset. 
 

h. Repeat for Land-Sea-Mask.  (GLOBAL, Land-Sea-Mask, <local path>/formulas/land-sea-mask) 
Open.  Add Dataset. 
 

i. Click OK to close the ADDE Data Manager. 
 

11. Load your Big Blue Marble basemap using the Flat files chooser: 
 
a. From the Data Sources tab of the Data Explorer, open the General tree and select Flat files. 

 
b. Select <local path>/formulas/basemap/blue-marble.jpg for the file to load. 

 
c. For Navigation, select Bounds.   Enter 90 for upper lat, -180 for upper lon, -90 for lower lat and 180 

for lower lon. 
 

d. Click Add Source, and from the Field Selector, click Create Display. 
 

12. Add your Sea Surface Temperature data source. 
 
a. From the Data Source tab of the Data Explorer, open the Satellite tree and select Imagery. 

 
b. The Server should be <LOCAL-DATA>. 

 
c. Enter GLOBAL for Dataset and click Connect. 

 
d. Set the value for the Image Type to SST. 

 
e. Select the Absolute tab, highlight the 2010-10-20 00:00:00Z time, and click Add Source. 
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13. Add your Land/Sea Mask data source. 
 
a. From the Data Sources tab of the Data Explorer, open the Satellite tree and select Imagery. 

 
b. The Server should be <LOCAL-DATA>. 

 
c. Enter GLOBAL for Dataset and click Connect. 

 
d. Set the value for the Image Type to Land-Sea-Mask. 

 
e. Select the Absolute tab, highlight the 2009-07-30 18:00:00Z time, and click Add Source. 

 
14. Create a display of Sea Surface Temperatures over just water areas: 

 
a. In the Field Selector, select Formulas. 
 
b. Open the Image Filters (Beta) tree and select Discriminate Image filter, and click Create Display. 

 
c. From the Select input window, enter the following: 

 
brkpoint1: 0 
brkpoint2: 255 
brkpoint3: 8 
brkpoint4: 8 
replace: 0 
 
Breakpoints 1 and 2 specify the range from the first dataset to be used, and break points 3 and 4 are 
for the second dataset.  In this example, values of 8 are used from the land/sea mask and represent 
water regions. 
 

d. Click OK. 
 

e. To define image1 in the new Field Selector window, select SST -> Band 1 -> Brightness. 
 

f. Select the Advanced tab. Click the full size icon 
(shown in the image on the right). Also, set the 
Coordinate Type to be Area Coordinates, and 
the Location to be Upper Left. Make sure your 
Advanced tab’s fields are filled in the same as 
they are in the image on the right. 
 

g. Repeat steps e and f to define image2 as Land-
Sea-Mask -> Band 1 -> Brightness.  Click OK 
for the land-sea mask to be displayed in the 
Main Display. 
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15. Change the color bar for the SST display and add some transparency to the color enhancement. 
 

a. From the Legend, right-click on the color bar of the SST - Image Display and select  
System -> Temperature to change the color table.   
 

b. Right click on the color bar again and select Edit Color Table. 
 

c. Right click above the color bar, select Add Breakpoint -> At Data Point.  Enter a value of 2 and click 
OK (as seen in figure to the lower-left). 
 

d. From the Transparency drop down box, select a value of 100%. 
 

e. Right click on the breakpoint you just created, select Edit Colors -> Transparency(100%) -> Left 
This sets transparency to 100% for all brightness values less than 2 (as seen in figure to the lower-right). 
 

f. Click OK to close the Color Table Editor. 
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16. Create and display the Water Vapor image. 

 
a. From the Data Sources tab of the Data Explorer, open the Satellite tree and select Imagery. 

 
b. The Server should be <LOCAL-DATA>. 

 
c. Enter GLOBAL for Dataset and click Connect. 

 
d. Set the value for the Image Type to WV. 

 
e. Select the Absolute tab, highlight the 2010-10-18 00:00:00Z image, and click Add Source. 

 
f. From the Field Selector, open the 6.8 um tree, select Brightness, and click Create Display. 

 
17. Add Transparency to the Water Vapor Imagery.  Use the same techniques as found in step 7. 

 
a. From the Legend, right-click on the color 

bar of the WV - Image Display and 
select Edit Color Table. 
 

b. Add a breakpoint at the 135 data point, 
set the transparency to 100% and fill to 
the left (Edit Colors -> Transparency -> 
Left). 
 

c. Create another breakpoint at 200 and set 
the transparency to 0%. Now interpolate 
the transparency to the left (Edit Colors -
> Transparency -> Interpolate -> Left). 
 

d. Click OK to close the Color Table 
Editor.  
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Creating your own Formulas – Simple Example  
 
18. Add your custom formula to McIDAS-V.   

 
a. From the menu in the Main Display, select Tools -> Formulas -> Create Formula. 

 
b. In the Name text box, enter:  Global Convective Diagnostic from WV and IR. 

This value will be shown when you mouse over the formula in the Field Selector. 
 

c. In the Formula text box, enter:  WaterVaporTemperature – InfraredTemperature 
Give your variables meaningful names.  These will be listed in the Field Selector. 
 (Note:  No spaces are allowed in the variable names.) 
 

d. Click the arrows next to Advanced. 
 

e. In the Description text box, enter:  GCD 
This value will be seen in the list of formulas in the Field Selector. 
 

f. In the Group text box enter:  Workshop 
You can create a tree structure of multiple groups – each of which can contain multiple formulas. 
 

g. Click Add Formula. 
 

19. Add Water Vapor and Infrared data sources to use with the GCD formula. 
 
a. Remove All Layers and Data Sources by selecting Edit -> Remove -> Remove All Layers and Data 

Sources in the Main Display. 
 

b. From the Data Sources tab of the Data Explorer, open the Satellite -> Imagery chooser, and connect 
to the <LOCAL-DATA> Global dataset. 
 

c. Set the Image Type to WV, and select the Absolute image time of 2010-10-18 00:00:00Z. 
 

d. Click Add Source. 
 

e. From Data Sources, set the Image Type to IR, and select the Absolute image time of 2010-10-18 
00:00:00Z. 

 
f. Click Add Source. 
 

20. Display a new image with the GCD formula applied. 
 
a. In the Field Selector tab, select Formulas under Data Sources. 

 
b. Under Fields, open the Workshop tree and select GCD. Select Imagery -> Image Display display type. 

Click Create Display. 
 

c. In the new Field Selector, for WaterVaporTemperature, select WV -> 6.8 um -> Temperature. 
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d. In the Advanced tab, click the full size icon and change Coordinate Type to Area Coordinates and 
Location to Upper Left. Make sure the other fields are filled as seen below: 
 

 
 

e. From the Region tab, select a small region around central Africa. 
 

f. For InfraredTemperature, select IR -> 10.7 um -> Temperature, and click OK. 
 

The Results of the GCD formula are displayed in the Main Display. 
 

 
Zooming, Panning, and Rotating Controls 

 
Zooming Panning Rotating 

 Mouse  
Shift-Left Drag: Select a region 
by pressing the Shift key and 
dragging the left mouse button. 
Shift-Right Drag: Hold Shift key 
and drag the right mouse button. 
Moving up zooms in, moving 
down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 
mouse to pan. 

Right Mouse Drag: Drag right 
mouse to rotate. 

 Scroll Wheel  
Scroll Wheel-Up: Zoom Out. 
Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-
Up/Down: Rotate 
clockwise/counter clockwise. 
Shift-Scroll Wheel-Up/Down: 
Rotate forward/backward 
clockwise. 

 Arrow Keys  
Shift-Up: Zoom In. 
Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 
Control-Down arrow: Pan Up. 
Control-Right arrow: Pan Left. 
Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 
around vertical axis. 
Up/Down arrow: Rotate 
around horizontal axis. 
Shift-Left/Right arrow: Rotate 
Clockwise/Counterclockwise. 

 
 


