
McIDAS-V Tutorial 
Displaying Gridded Data 

updated June 2012 (software version 1.2) 
 

 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 
SSEC's 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 
manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 
Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands 
and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being 
integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data. 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 
McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 
the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 
http://www.ssec.wisc.edu/mcidas/software/v/.   

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 
Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share 
information with other users. 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 
McIDAS-V.  If you can not start McIDAS-V on your machine, you should follow the instructions in the 
document entitled McIDAS-V Tutorial – Installation and Introduction.   

In this McIDAS-V Tutorial, each exercise will be explained using two different methods of data access:  pre-
loaded data bundles and real-time access to default remote servers.  If you have access to your own real-time 
servers, you may also use those, but be aware that different server configurations may make the explanations in 
this document not quite applicable to all data that you may load.   

 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 
Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 
Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 
Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit ->Remove ->All Layers and Data Sources). 
 
Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).   

 
 



Page 2 of  9 

McIDAS-V Tutorial – Displaying Gridded Data                                                                   June 2012 – McIDAS-V version 1.2 

Displaying Gridded data: 2D 
 
1. Remove all layers and data sources from the previous displays. 
 
2. If you are using real-time data, skip to step 3. Otherwise, load data bundle  
      <local path>/Gridded/Grid-GFS-Intro.mcvz.   
 

a. In the Main Display, select File -> Open File... 
 

b. Navigate to the Grid-GFS-Intro.mcvz file and click Open. 
 

c. In the “Open Bundle” dialog box, select the Replace session option and click OK. 
 
3. If you are using real-time data, follow the instructions below. 
 

a. Select the Gridded Data -> Remote chooser from the Data Sources tab.   
 

b. From the Catalog pull down menu, select http://motherlode.ucar.edu:8080/thredds/idv/models.xml. 
 

c. Add the NCEP Model Data -> Global Forecast System Model -> NCEP GFS CONUS 80 km  -> 
Latest source. 

 
4. Display the MSL Pressure.   
 

a. In the Field Selector select the 2D grid -> Pressure reduced to MSL @ msl field. 
 

b. Select the Color-Shaded Plan View Display. 
 
c. In the Times tab, uncheck the Use Default checkbox and select the first six times. 

 
d. Create the Display. 

 
5. In the Layer Controls, turn on the option to Shade Colors.   
 
6. Go back to the Field Selector, change the Display type to 

Contour Plan View, and overlay the same parameter.   
 

7. In the Layer Controls, click on the Color Table name 
(PressureMSL) to change the color table of the contours to 
System -> Solid Colors -> Black.   
 

8. Zoom in over a region to see a display like that to the right. 
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Displaying Gridded data: 3D 
 
1. Remove all layers.  In the Field Selector, select the 3D grid -> Temperature @ isobaric field. 
 

a. Select the Color-Filled Contour Plan View display type. 
 
b. In the Times tab select the first 6 images. 

 
c. In the Level tab, select 500 hPa. 

 
d. Click Create Display.   

 
2. Use the rotating and zooming controls to rotate the Main Display window. You can see that the 500hPa 

surface is displayed above the map layer. 
 

3. Keep the Main Display rotated so the difference in height between the map and the display can be seen. 
 
4. In the Layer Controls, use the Levels pull down menu to change the level of the contours.  Note that when 

the level is changed, both the display and the z-level of the display change in the Main Display. 
 

a. Change the level to 850 hPa. 
 

b. Change the contour interval to 10 Celsius by clicking on the Change button in the Contour section of 
the Layer Controls.   

 
5. Reset the projection and change the level to 250 hPa. You should notice that the map does not show up on 

the contours. 
 
6. Move the map above the 250 hPa contours and change the map colors to white. 
 

a. In the Layer Controls, select “Default Background Maps” from the list of layers on the left side of the 
tab. 
 

b. In the Settings tab, move the Map Position slider to the right to move higher into the 3D display. 
 
c. Change the map colors of “North & Central America”,  “World Political Boundaries” , and “World 

Coastlines” to white. 
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Problem Sets 
 
The previous examples were intended to give you a general knowledge of how to load and display gridded 
data.  The problem sets below are intended to introduce you to new topics related to the data, as well as 
challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set 
before looking at the solutions, which are provided below the problem set. 
 
1. Create a display of 2D Pressure as a 3D Color Shaded Image Over Topography display using the most 

recent time.  Overlay Absolute Vorticity as an isosurface using the most recent time.  Then, remove the 
Absolute Vorticity layer and add a cross section of Relative Humidity using the most recent time.   
 

2. Create a 3D globe display of jet stream winds and 2D surface pressure from grids for the first three times.  
Use the bundle <local path>/Gridded/Grid-Problem-Globe.mcvz to load the grids. Create a movie of 
your display rotating and playing the loop.  Note:  This bundle is large, so it may take a minute to open the 
file. 
 

3. Create a display showing the difference between the 0Z and 6Z 2D Pressure Reduced to MSL @ msl field 
for 2009-05-29 00:00:00Z.   Change the units to millibars and then change the range to match the new units.  
Save a JPG image of the difference.  You may use bundle  
<local path>/Gridded/Grid-Problem-Difference.mcvz or real-time data to load the grids. If you are using 
real-time data, do not use the 2009 time, but choose one individual time to use or both model runs. 

 
 
Problem Set #1 – Solution 
 
Create a display of 2D Pressure as a 3D Color Shaded Image Over Topography display using the most recent 
time.  Overlay Absolute Vorticity as an isosurface using the most recent time.  Then, remove the Absolute 
Vorticity layer and add a cross section of Relative Humidity using the most recent time.   
 
1. Remove all layers. 
 
2. Create a new tab. 
 
3. Add the first five times for 2D Pressure reduced to MSL @ msl and display it as a 3D Color-Shaded Image 

Over Topography display.  The 2D field will be displayed as topography. 
 

a. You will be prompted for the Topography field.  Select the Latest NCEP GFS CONUS 80km -> 
Geopotential_height @ surface field from the selector, the earliest time, and press OK. 
 

b. Shade the colors, and use the zooming and rotating controls to see the display in 3D. 
 

4. Reset the display projection. 
 
5. Display the earliest 3D grid -> Absolute Vorticity @ isobaric as a 3D isosurface. 
 
6. Zoom in over the US and rotate the display to see the absolute vorticity isosurface over the continental US. 
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7. The Isosurface Value in the Layer Controls can be used to change the value of absolute vorticity displayed. 
Change the value to 5 x 1.0e-5 s-1. 

 
 
8. Remove the absolute vorticity isosurface layer from the display. 
 
9. Add the earliest 3D Relative Humidity @ Isobaric as a Color-Filled Contour Cross Section.  Click Create 

Display. The cross section will be displayed in 3D in the Main Display window and in 2D in the Layer 
Controls. 
 

10. To reposition the cross section in the main window, left-click on the plus or square to move the ends of the 
cross section, and the triangle to move the entire line.  
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Problem Set #2 – Solution 
 
Create a 3D globe display of jet stream winds and 2D surface pressure from grids for the first three times.  Use 
the bundle <local path>/Gridded/Grid-Problem-Globe.mcvz to load the grids. Create a movie of your display 
rotating and playing the loop.  Note:  This bundle is large, so it may take a minute to open the file. 
 
1. Add a one panel globe display tab by selecting File -> New Display Tab -> Globe Display -> One Panel.   
 
2. Load bundle <local path>/Gridded/Grid-Problem-Globe.mcvz via the File -> Open File… menu item in 

the Main Display.  In the “Open Bundle” dialog box select the Replace session option and click OK.  This 
is a large dataset, so it may take a minute to open the file. 
 

3. Display the first three 2D Temperature at Surface grids as a Color-Filled Contour Plan View.  Overlay it 
again as contours.   

 
4. Next, display the 3D -> Momentum -> Derived -> Speed grid as a 3D Isosurface for the same times. 

 
5. In the Layer Controls, change the following: 
 

a. Change isosurface value to 60 m/s for Speed.   
 

b. Change the default World Coastlines map color to RGB 0-153-204 and the default World Political 
Boundaries map color to RGB 0-255-255.  This is done by going to the Default Background Maps, 
select the color square next to your desired map and navigating to the RGB tab. 

 
6. Start the loop and turn on the Auto-Rotate View option (View -> Viewpoint -> Auto-Rotate View from the 

Main Display).  Use the Zooming and Panning controls to observe the data from different views.  
(Depending on preference, it might help to turn the Auto-Rotate View option off.) 
 

7. Turn the looping on and make sure the Auto-Rotate View option is on.   
 
8. Capture a movie of the rotating globe by selecting View -> Capture -> Movie…  in the Main Display. 
 

a. In the Movie Capture window, 
change Rate: to 0.25 seconds.   

 
b. Move the Main Window and 

the Movie Capture window 
around so they do not overlap.  
(During the movie capture, if 
the view in the Main Window 
is obscured, the obscurities will 
be shown in the capture.)   
 

c. Start the movie capture by 
clicking Automatically. 
 

d. Once the globe has rotated 360°, click Stop.  Click Save Movie to save it as a QuickTime movie. 
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Problem Set #3 – Solution 
 
Create a display showing the difference between the 0Z and 6Z 2D Pressure Reduced to MSL @ msl field for 
2009-05-29 00:00:00Z.   Change the units to millibars and then change the range to match the new units.  Save 
a JPG image of the difference.  You may load the grids using real- time data or bundle  
<local path>/Gridded/Grid-Problem-Difference.mcvz. If you are using real-time data, do not use the 2009 
time, but choose one individual time to use on both model runs. 
 
1. Open a new tab, and close the globe display tab. 
 
2. If you are using real-time data, skip to step 3.  Otherwise, load the data bundle Grid-Problem-

Difference.mcvz.  In the “Open Bundle” dialog box select the Replace session option and click OK. 
 
3. If you are using real-time data, follow the instructions below. 
 

a. Remove all layers and data sources. 
 
b. Return to the Data Sources tab, and load the 0Z and 6Z GFS Global 1° grids (NCEP Model Data -> 

Global Forecast System Model -> NCEP GFS Global 1 degree -> 
GFS_Global_onedeg_YYYYMMDD_0000.grib2 (0600.grib2) ) for today into the Field Selector. 
 

4. Choose Formulas in the Field Selector, and select Miscellaneous -> Simple difference a-b. 
 
5. In the Displays tab select Plan Views -> Color-Shaded Plan View and click Create Display.  A Field 

Selector window will pop up prompting you for the two fields to subtract.  You may need to expand the 
window to see the full descriptions. 

 
a. On the left, select the 0Z run Pressure Reduced to MSL @ msl field and 2009-05-29 00:00:00Z. 
 
b. On the right, select the 6Z run Pressure Reduced to MSL @ msl field and 2009-05-29 00:00:00Z in the 

Times tab.  Click OK. 
 

6. The resulting plot will show the difference between the two grids in Pascals.  Change this to millibars. 
 

a. In the Layer Controls, select Edit -> Change Display Unit…   
 
b. Select millibar from the dropdown list and click OK.  To change the range of data values with the new 

units, right-click on the color bar in the Legend and select Change Range. Click on Use Predefined -> 
From All Data and click OK. Positive values indicate the 0Z forecast predicted a higher pressure than 
the 6Z, and negative values indicate the opposite.   
 

7. Save the Main Display window as an image.  
Select View -> Capture -> Image… from the 
Main Display. 

 
a. Under “Capture What”, change the radio 

button to Full Window. 
 
b. Enter in a name, followed by the “.jpg” 

extension and click Save. 
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Challenge 
 
The bundle <local path>/Gridded/Grid-Problem-Challenge.mcvz contains 3D u and v data.  Use the 
available data and display options to look for a jet entrance or exit region. 
 
For a reminder of jet entrance and exit regions, see the graphic below from: 
http://www4.ncsu.edu/~nwsfo/storage/training/jets/JETS.gifs/JET.4Cell.A.gif 
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Zooming, Panning, and Rotating Controls 
 

Zooming Panning Rotating 
 Mouse  
Shift-Left Drag: Select a region 
by pressing the Shift key and 
dragging the left mouse button. 
Shift-Right Drag: Hold Shift key 
and drag the right mouse button. 
Moving up zooms in, moving 
down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 
mouse to pan. 

Right Mouse Drag: Drag right 
mouse to rotate. 

 Scroll Wheel  
Scroll Wheel-Up: Zoom Out. 
Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-
Up/Down: Rotate 
clockwise/counter clockwise. 
Shift-Scroll Wheel-Up/Down: 
Rotate forward/backward 
clockwise. 

 Arrow Keys  
Shift-Up: Zoom In. 
Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 
Control-Down arrow: Pan Up. 
Control-Right arrow: Pan Left. 
Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 
around vertical axis. 
Up/Down arrow: Rotate 
around horizontal axis. 
Shift-Left/Right arrow: Rotate 
Clockwise/Counterclockwise. 

 


