
McIDAS-V Tutorial 
Displaying Level II Radar Imagery 
updated June 2012 (software version 1.2) 

 
 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 
SSEC's 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 
manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 
Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands 
and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being 
integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data. 
 
More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 
McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 
the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 
http://www.ssec.wisc.edu/mcidas/software/v/ .  
 
If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 
Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share 
information with other users.  
 
In this McIDAS-V Tutorial, some exercises will be explained using local data files included in pre-loaded data 
bundles. If you have access to your own real-time ADDE servers, you may also use those, but be aware that 
different server configurations may make the explanations in this document not quite applicable to all data that 
you may load.  

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 
McIDAS-V. If you cannot start McIDAS-V on your machine, you should follow the instructions in the 
document entitled McIDAS-V Tutorial – Installation and Introduction. 

 
Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 
Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 
Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 
Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit ->Remove ->All Layers and Data Sources). 
 
Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).   
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Displaying Level II radar images: 2D and 3D reflectivity swaths 
 
The Radar Sweep View in 2D display creates a 2-dimensional display of 3-dimensional radar data at individual 
elevation angles. While only data from only one elevation angle can be displayed at once, you can cycle through 
different elevation angles to help to determine the 3-dimensional characteristics of the data. 
 
The Radar Sweep View in 3D display creates a 3-dimensional display of radar data at individual elevation 
angles. While only data from only one elevation angle can be displayed at once, you can cycle through different 
elevation angles to inspect the 3-dimensional characteristics of the data. This display appears to be identical to 
the Radar Sweep View in 2D display until the image is rotated, giving a perspective of altitude of the data. 
 
1. Remove all Layers and Data Sources from the previous displays via the Edit -> Remove -> All Layers and 

Data Sources menu item in the Main Display. 
 

2. Load the <local path>/Radar/Radar.mcvz bundle into McIDAS-V.  Select File -> Open File… from the 
menu in the Main Display. Navigate to the directory containing the bundle, select the bundle, and click 
Open. In the Open Bundle dialog box select the Replace session option and click OK. 

 
3. Open a two panel map display by selecting File -> New Display Tab -> Map Display -> Two Panels menu 

item in the Main Display. 
 

a. By default, the right panel is highlighted by a blue box, which means this is where the data will be 
displayed. Click the left panel, and you should see the blue box outline the panel display, indicating it is 
selected.  Any displays created will be added to the selected panel. 

 
b. To change the outline color, select Edit -> Preferences.  Under the Display Window tab, there is a Color 

Scheme section on the right side.  To the right of Selected Panel, click the blue box to bring up the Set 
Selected Panel Border Color window.  Select a new color from the swatches and click OK.  Click OK 
to close the User Preferences window.  Switch between panels to refresh the box to the selected color. 

 
4. Display the 2D View in the left panel. 

 
a. Under Fields in the Field Selector, select the Reflectivity entry.  The available displays will show up 

under Displays.  Choose the Radar Sweep View in 2D display.   
 

b. Click Create Display. 
 

5. Display the 3D View in the right panel. 
 
a. Select the right panel of the Main Display, and return to the Field Selector. 

 
b. Select the Radar Sweep View in 3D display and click Create Display.   

 
6. There is no visible difference between the two layers until the view is rotated away from the top. Right click 

+ drag or use the navigation toolbar in the left side of the Main Display to rotate the display. Turn looping 
on and off as you navigate through the 3D reflectivity image. 
 

7. A default for multi-panel displays is shared views, which means that as one panel’s navigation changes, they 
all move in sync.  To turn this feature off, go to a panel and uncheck Projections -> Share Views. 
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Displaying Level II radar images: RHI 
 
The RHI (Range-Height Indicator) display is utilized to observe the 3-dimensional characteristics of radar data 
at various elevation angles. Every elevation angle included with the data will be used to create this display. This 
display creates a chart that has distance as the x-axis, and altitude as the y-axis. The distance component of the 
display is derived from the transect line, which has one endpoint at the location of the radar, and another at a 
user-defined latitude/longitude location. 
 

 
 

8. Add an RHI layer to the left panel. 
 

a. Select the left panel, turn the looping off and return to the Field Selector.     
 

b. In the Field Selector, select RHI under Displays, and click Create Display. 
 
c. Rotate to the Top Viewpoint by clicking on the  button on the left toolbar.   
 
d. Left click + drag on the square at the end of the line to change the position of the RHI line.  The 2D 

display in the Layer Controls will automatically update as the RHI line moves. 
 

e. Right click + drag in the left panel of the Main Display to visualize the vertical component of the RHI 
display. 
 

9. Rotate the reflectivity azimuth in both the Main Display window and the Display tab of the Layer Controls. 
 

a. In the Settings tab of the Layer Controls for RHI, click Start next to Autorotate RHI.  This will rotate 
the reflectivity azimuth in both the Main Display window and in the Display tab of the Layer Controls. 
 

b. When you are done, go back to the Settings tab and Stop the Autorotate. 
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Displaying Level II radar images: Radar Cross Section 
 
The Radar Cross Section display is very similar to the RHI display. This display type is useful for observing the 
3-dimensional characteristics of radar data at various elevation angles. Every elevation angle included with the 
data will be used to create this display. This display creates a chart that has distance as the x-axis, and altitude 
as the y-axis. The distance component of the display is derived from the transect line. Each endpoint of this 
transect line is at a user-defined latitude/longitude location, so neither endpoint is necessarily designated as the 
location of the radar. 

10. Open a new tab by clicking on the  button in the main toolbar. 
 

11. Close any previously existing tabs. 
 

12. In the Field Selector, display the Radar Cross Section display. 
 
a. Select the Reflectivity tree in the Fields panel. 

 
b. In the Displays panel, select Radar Cross Section, and click Create Display. 

 
13. In the Main Display, left click+ drag the endpoints of the cross section to reposition them. Use right 

click+drag to navigate through the display in the 3D. Note that the display is duplicated in the Layer 
Controls tab of the Data Explorer. 

 
 
Displaying Level II radar images: Radar Sweep as Topography 
 
The Radar Sweep as Topography display is a unique display type that helps to better visualize 2-dimensional 
radar data. This display type derives a 3-dimensional display from 2-dimensional data, making the display have 
various high and low vertical components based upon the numerical value of the parameter you are displaying. 
Only one elevation angle of radar data is used to create this display. 

14. Open a new tab by clicking on the  button in the main toolbar. 
 

15. Close any previously existing tabs. 
 

16. In the Field Selector, display the Radar Sweep as Topography display. 
 
a. Open the Reflectivity tree in the Fields panel to see the individual elevation angles. 

 
b. Select the Reflectivity Elevation Angle .5 field 

 
c. In the Displays panel, select Radar Sweep as Topography, and click Create Display. 

 
17. Right click + drag in the Main Display to observe the 3D features of the display. 
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Displaying Level II radar images: CAPPI 
 
The CAPPI (Constant Altitude Plan Position Indicator) display is used to visualize the 2-dimensional 
characteristics of radar data at various altitudes. Every elevation angle included with the data will be used to 
create this display. Dependent on the altitude you select to display, you may see various rings of data. These 
rings indicate the radar display created from different elevation angles at the user-defined altitude. 
18. Open a new tab by clicking on the  button in the main toolbar. 

 
19. Close any previously existing tabs. 

 
20. In the Field Selector, display the CAPPI radar display. 

 
a. In the Fields panel, select Reflectivity. 

 
b. In the Displays panel, select CAPPI. 

 
c. Click Create Display. 

 
21. In the Layer Controls tab, change the Levels menu item to change the vertical level displayed in the Main 

Display. You can also click the Cycle checkbox to animate through the levels in the vertical. 
 

22. The Display Mode can be changed to Mesh or Points. This can make it easier to see any display that may 
otherwise be hidden underneath the radar display. 

 
 
Displaying Level II radar images: Volume Scan 
 
The Volume Scan display is used to visualize the 3-dimensional characteristics of radar data in all directions 
from the location of the radar. Every elevation angle included with the data will be used to create this display. 
This is similar to the Radar Sweep View in 3D display, with the exception that this display plots data for every 
elevation angle at once. In order to be able to visualize data from various elevation angles at once, the data is 
displayed as points instead of as a solid surface. 

23. Open a new tab by clicking on the  button in the main toolbar. 
 

24. Close any previously existing displays. 
 

25. In the Field Selector, display the Volume Scan.   
 
a. Select the Volume Scan display. 

 
b. Select only one image time by turning off the Use Default checkbox in the Times tab of the Field 

Selector, and select one time.  
 

c. Click Create Display.   
 

26. Right click + drag in the Main Display to observe the 3D view of all radar sweeps in the Layer Controls.   
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Displaying Level II radar images: Radar Isosurface 
 
The Radar Isosurface display is used to visualize 3-dimensional characteristics of radar data in all directions 
from the location of the radar. Every elevation angle included with the data will be used to create this display. 
Instead of plotting data at all numerical values, a solid surface of only one user-defined data value will be 
displayed. One example use of this display would be selecting a high reflectivity value that may be indicative of 
hail, which can help to possibly identify the hail core of a thunderstorm. 

27. Open a new tab by clicking on the  button in the main toolbar. 
 

28. Close any previously existing tabs. 
 

29. In the Field Selector, display the Radar Isosurface. 
 
a. Select the Radar Isosurface display. 

 
b. Click the Use Default box by the times to use all of the times for the display. 
 
c. Click Create Display. 

 
d. In the Layer Controls, change the Isosurface Value to 30 and press Enter. 

 
e. Add range rings to the display by selecting Display -> Add Range Rings in the Main Display. 

 
f.    Animate the display by pressing Play in the Time Animation Control widget. Right click + drag in the 
Main Display to observe the 3D characteristics of the Radar Isosurface display. 

 
 
Problem Sets 
 
The previous examples were intended to give you a general knowledge of how to load and display radar data. 
The problem sets below are intended to introduce you to new topics related to the data, as well as challenge 
your knowledge of McIDAS-V. We recommend that you attempt to complete each problem set before looking 
at the solutions, which are provided below the problem set. 
 
1. Load the KDDC bundle into McIDAS-V. This bundle contains radar data over Dodge City, Kansas from 

2007, when an EF-5 tornado occurred. Create a three panel display that will help identify the location of the 
tornado. In the first panel, display a Radar Sweep View in 2D display of Reflectivity. In the second panel, 
display a Radar Sweep View in 2D display of Radial Velocity. Finally, in the third panel, create a Radar 
Sweep View in 2D display of Spectrum Width. Add county outlines to the map backgrounds in all three 
panels. Change the enhancement of the Radial Velocity to Radar->Base Radial Velocity. Change the 
Spectrum Width data range to 0 – 20. Add a color bar to the top of each panel. Change the name of the tab 
to ‘KDDX Radar Displays’. Change the name of each panel to represent the field that is being displayed (ex. 
Reflectivity). Attempt locating the tornado by interrogating the displays. Probe the data with the middle 
mouse button. 
 

2. Create a Data Probe/Time Series display of reflectivity data. Hint: To help position the data probe, first 
create a Radar Sweep View in 2D display. 
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Problem Set #1 – Solution 
 
Load the KDDC bundle into McIDAS-V. This bundle contains radar data over Dodge City, Kansas from 2007, 
when an EF-5 tornado occurred. Create a three panel display that will help identify the location of the tornado. 
In the first panel, display a Radar Sweep View in 2D display of Reflectivity. In the second panel, display a 
Radar Sweep View in 2D display of Radial Velocity. Finally, in the third panel, create a Radar Sweep View in 
2D display of Spectrum Width. Add county outlines to the map backgrounds in all three panels. Change the 
enhancement of the Radial Velocity to Radar->Base Radial Velocity. Change the Spectrum Width data range 
to 0 – 20. Add a color bar to the top of each panel. Change the name of the tab to ‘KDDX Radar Displays’. 
Change the name of each panel to represent the field that is being displayed (ex. Reflectivity). Attempt locating 
the tornado by interrogating the displays. Probe the data with the middle mouse button. 
 
1. Remove all Layers and Data via the Edit -> Remove -> All Layers and Data Sources menu item in the 

Main Display. 
 

2. Create a three panel display via the File -> New Display Tab -> Map Display -> Three Panels menu item in 
the Main Display.  Close any previously existing tabs. 
 

3. Load in the <local path>/Radar/KDDC.mcvz bundle through the File -> Open File menu item in the Main 
Display. This will add the data to the Field Selector. 
 

4. Click the first panel on the left to make this panel active. Select the Reflectivity field and the Radar Sweep 
View in 2D display. Click Create Display. 
 

5. Click in the middle panel to make this panel active. Select the Radial Velocity field and the Radar Sweep 
View in 2D display. Click Create Display. 
 

6. Click on the third panel to make this panel active. Select the Spectrum Width field and the Radar Sweep 
View in 2D display. Click Create Display. 
 

7. In the Layer Controls tab, go to the Default Background Maps controls for each panel. Check the box next 
to U.S. County Outlines for each panel to add county map outlines to each panel. 
 

8. Add a color bar to each panel by individually going to the Layer Controls tab of the Data Explorer for each 
field. In the menus of the Layer Controls, select Edit -> Properties. In the Properties window, go to the 
Color Scale tab, click the Visible checkbox. Select the Top Position. Change the font size to 20, and the 
text to Bold. Click OK. 
 

9. In the Layer Controls tab for the Radial Velocity field, change the color table to Radar -> Base Radial 
Velocity. Do this by clicking on the button to the right of Color Table, and navigating to the specified color 
table in the dropdown menu. 
 

10. In the Layer Controls tab for the Spectrum Width field, change the range to 0 – 20. Do this by clicking on 
the button to the right of Color Table, and selecting Change Range…. In the From field, enter 0. In the To 
field, enter a value of 20. Click OK to close the Change Range window. 
 

11. Change the name of the tab from ‘untitled’ to ‘KDDC Radar Displays’. Do this by double clicking on the 
tab below the toolbar. This opens a McIDAS-V – Rename Tab window. Enter ‘KDDC Radar Displays’ 
into the field, and press OK. 
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12. Change the name of each panel individually by going through the View -> Properties menu item. In the 
Main tab of the Properties window, change the Name of the first panel to ‘Reflectivity’. Use the same 
method to change the name of the second panel to ‘Radial Velocity’, and the third panel to ‘Spectrum 
Width’.  You may need to increase the width of your window to see the panel names.   
 

13. Interrogate the data in the three panels and attempt locating the position of the tornado. Play through the 
loop using the Time Animation Controls. 
 
 

Problem Set #2 – Solution 
 
Create a Data Probe/Time Series display of reflectivity data. Hint: To help position the data probe, first create a 
Radar Sweep View in 2D display. 
 
1. Remove all Layers via the Edit -> Remove -> All Layers menu item in the Main Display. 

 
2. Create a new, one panel tab via the File -> New Display Tab -> Map Display -> One Panel menu item in 

the Main Display. 
 

3. Close any previously existing tabs. 
 

4. In the Layer Controls tab, select the Reflectivity field, and the Radar Sweep View in 2D display type. Click 
Create Display. 
 

5. In the Layer Controls tab, select the Reflectivity field and the Data Probe/Time Series display type. Click 
Create Display.  This will place a square probe in the Main Display overtop of the Radar Sweep View 
display. A time series at this probe location will be plotted in the Layer Controls tab of the Data Explorer. 
 

6. Play through the loop of data in the Main Display, and position the probe at an interesting location with 
respect to the reflectivity. As you move the data probe via left-click+drag, the Data Probe/Time Series 
display will automatically change. 
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Zooming, Panning, and Rotating Controls 
 

Zooming Panning Rotating 
 Mouse  
Shift-Left Drag: Select a region 
by pressing the Shift key and 
dragging the left mouse button. 
Shift-Right Drag: Hold Shift key 
and drag the right mouse button. 
Moving up zooms in, moving 
down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 
mouse to pan. 

Right Mouse Drag: Drag right 
mouse to rotate. 

 Scroll Wheel  
Scroll Wheel-Up: Zoom Out. 
Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-
Up/Down: Rotate 
clockwise/counter clockwise. 
Shift-Scroll Wheel-Up/Down: 
Rotate forward/backward 
clockwise. 

 Arrow Keys  
Shift-Up: Zoom In. 
Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 
Control-Down arrow: Pan Up. 
Control-Right arrow: Pan Left. 
Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 
around vertical axis. 
Up/Down arrow: Rotate 
around horizontal axis. 
Shift-Left/Right arrow: Rotate 
Clockwise/Counterclockwise. 

 


