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McIDAS-V Tutorial

Displaying Polar Satellite Imagery
updated May 2012 (software version 1.2)
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.
More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .  

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other users.

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.  
Terminology

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).
Loading Polar Satellite Images and Loops
1. Create a local dataset to access the imagery files on your local machine.

a. In the Main Display window of McIDAS-V, select Tools -> Manage ADDE Datasets.
b. In the ADDE Data Manager, select File -> New Local Dataset.  Enter in the following parameters to set up a dataset with the MODIS Level 1b HDF files provided with this tutorial: 


· Dataset – MODIS

· Image Type – 1 km HDF MOD02 1 km files

· Format – MODIS MOD 02 – Level-1B Calibrated Geolocated Radiances

· Directory – select the <local path>/Polar/modis_files directory
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c. Close the ADDE Data Manager by clicking “X” in the upper right-hand corner or select File -> Close.

2. To load the data in this local dataset, follow these steps.
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Click on the [image: image1.png]


 button in the main toolbar to go to the Data Explorer.  

b. Select the Satellite -> Imagery chooser from the Data Sources tab. 

c. Select <LOCAL-DATA> for Server:, select MODIS for Dataset:, click Connect.

d. Choose the 1km HDF MOD021KM files  Image Type and select an Absolute time of 02:50 UTC.  

e. Click Add Source to show the Field Selector.

f. Select 0.6465 um Land/Cloud Boundaries -> Brightness.
g. Click Create Display.  The 02:50 UTC 0.6465 μm image is displayed in the Main Display window.
3. Use the zooming and panning controls in the left toolbar to inspect the image.  
a. Reset the display projection by clicking on the [image: image2.png]


 icon below the zooming buttons on the left toolbar.

b. Reproject the image with a pre-defined domain.  Select Projections -> Predefined -> Asia.  Use the scroll wheel to zoom into the image or Shift + Left Click + Drag a box around the image.
c. Turn off the Auto-set Projection option under the Projections menu.  When this option is checked, the projection will automatically change to the native projection of the new layer.  When this option is unchecked, all new layers will be reprojected into the current projection.  
4. Edit the maps in the display by using the options in the Layer Controls.  
a. Click on Default Background Maps in the Legend to go to the Layer Controls.  The map controls will have two tabs.  The first Maps tab lists the available maps, and the second Settings tab allows the user to control latitude and longitude lines, as well as the Z level of the maps in the 3D display.  
b. In the Maps tab, you can remove a map, change its visibility, line width, style and color.  Use these options to create your own map display.  
c. If you choose, also add latitude and longitude lines in the Settings tab.  
d. To save a map configuration as the default, in the Layer Controls select File -> Default Maps -> Save as the Default Map Set.  The next time you open a new tab, window, or start McIDAS-V, the defaults will reflect what you selected.  
5. Return to the Field Selector  to load an infrared image.

a. Select  11.0186 um Surface/Cloud Temperature -> Temperature .  


b. Click Create Display.
6. The 11.0186 µm temperature image is overlaid on top of the visible image.  To see the visible image, turn off the top 1km HDF MOD021KM (All Bands...) checkbox in the Legend.  Turn the image back on and click and drag the middle mouse button to activate the Cursor/Data Readout option.  This option brings up a latitude, longitude, and data value readout in the upper left part of the display on a mouse drag.  Since there are two layers in the main display, there are two different readouts with the appropriate values and units.

7. Change the font and color of the labels on the Main Display.  


a. Choose Edit -> Preferences.  Click on Display Window.  


b. In the right column under Layer List Properties, change Font: to Arial/Plain/14.  Change the Color: to a yellow hue.  Click OK.  


c. Return to the Main Display to see the changes.
8. Notice the labels are the same in the Legend and on the main display window label.  This can be customized.

a. Right Click on the top Legend label 1km HDF MOD021KM (All Bands...).  


b. Choose Edit -> Properties... . Enter the following for the Legend Label and Layer Label:
· Legend Label – 11.0186 um TERRA
· Layer Label - %datasourcename% - 11.0186 um-  %timestamp%
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9. Return to the Data Sources  to load another time.

a. Select an Absolute time of 02:55 UTC.  Click Add Source.

b. A new data source is created in the Field Selector.  To distinguish it from the first data source, the label is editable.  Right Click on the highlighted 1km HDF MOD021KM (All Bands...) and choose Properties.  In the Name: field enter, 1km HDF 2:55 UTC MOD021KM.  Click OK.

c. Select 0.6465 um Land/Cloud Boundaries -> Brightness. 

d. Click Create Display.  The 02:55 UTC 0.6465 μm image is displayed in the Main Display window with the other displays also visible (because the Auto-set Projection setting is unchecked).

e. In the Legend, click on the trash can next to 11.0816 µm TERRA to remove the infrared display (the middle one listed with the color table range of 0 to 295.7).
10. Create a local dataset to access other polar orbiter imagery files on your local machine.
a. In the Main Menu Bar in the Main Display window of McIDAS-V, select Tools -> Manage ADDE Datasets.
b. In the ADDE Data Manager, select File -> New Local Dataset.  To set up a dataset with the HRPT (High Resolution Picture Transmission) NOAA-18 AREA files provided with this tutorial enter the following parameters: Dataset: HRPT  Image Type: HRPT N18 area files  Format: McIDAS AREA.  Under Directory:, select the <local path>/Polar/HRPT_areas directory.

c. In the ADDE Data Manager, select File -> New Local Dataset.  To set up a dataset with the GAC (Global Area Coverage) NOAA-18 AREA files provided with this tutorial enter the following parameters: Dataset: GAC  Image Type: GAC N18 area files  Format: McIDAS AREA.  Under Directory:, select the <local path>/Polar/GAC_areas directory.

d. Close the ADDE Data Manager by clicking “X” in the upper right-hand corner or select File -> Close.

11. Remove the satellite image layers from the previous display.
a. Select Edit -> Remove -> All Layers and Data Sources.  
b. Select <LOCAL-DATA> for Server:, select HRPT for Dataset:, click Connect.

c. Choose the HRPT N18 area files  Image Type and select an Absolute time of 04:45:04 UTC.  

d. Select Lat/Lon for the Navigation:.

e. Click Add Source to show the Field Selector.

f. Select  10.8 um Surface/Cloud-top Temp -> Temperature.  
g. Under Displays click on the Advanced tab.  Click on the green arrow icon to load the full image. Change the Magnification to 1 X 1 with the sliders, and click Create Display.  (The Magnification of 1 X 1 downloads the full resolution of the data.  Negative magnification values will reduce the amount of data downloaded.  For example, -5 X -5 will sample the data, and every fifth line and every fifth element is sent from the server.)

h. There are some bad data points in this image that cause the minimum and maximum values of the color table to be 0 and 6553.1.  Change the range of the color table by right clicking on the color table in the Legend, selecting Change Range..., and entering the values 330 and 180..  

12. Load an FY2E satellite image over the HRPT image.  This dataset was previously created in the Displaying Satellite Imagery tutorial.

a. From the Satellite -> Imagery chooser select <LOCAL-DATA> for Server:, select ZQ_IR for Dataset:, click Connect.
b. Choose the FY2E IR satellite data  Image Type and select an Absolute time of 05:01 UTC.

c. Click Add Source to show the Field Selector.

d. Select 10.8 um Surface/Cloud-top Temp -> Temperature.

e. Under Displays click on the Advanced tab.  Click on the green arrow icon to load the full image. Change the Magnification to 1 X 1 with the sliders, and click Create Display.

f. The Auto-set Projection is off from a previous exercise.  To change to the FY2E image’s projection, in the Main Display select Projections -> From Displays -> Image (GMSX) Projection from: Image Display.

13. Zoom the Main Display over the HRPT image and place the HRPT image over the FY2E image. 

a. Turn off the FY2E full disk image by unchecking the FY2E IR Satellite Data box in the Legend.
b. Shift + Left Click + Drag a box over the HRPT image to zoom into it.

c. Turn on the FY2E full disk image by rechecking the FY2E IR Satellite Data box in the Legend.
d. In the Legend, right-click on the HRPT N18 area files and select View -> Bring to Front.
14. Make the data ranges the same for both images and compare them.
a. In the Legend, right-click on the FY2E IR satellite data’s color table and select Change Range....  In the window enter From: 330 and To: 180.  Click OK.

b. Use the middle mouse button to click and probe the data for a temperature comparison. 
Problem Sets
The previous examples were intended to give you a general knowledge of how to load and display polar satellite data.  The problem set below is intended to introduce you to new topics related to the data, as well as challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete the problem set before looking at the solution, which is provided below the problem set.
1. Load a loop of GAC (Global Area Coverage) NOAA-18 images on a Globe Display.  Load visible and low-level water vapor images.  Animate the loop on a rotating globe.  Use the GAC N18 dataset created earlier in this tutorial.
2. Load a HRPT NOAA-18 image.  Display the polar orbit track for the image using a two-line element text file with the Polar Orbit Track chooser.  Add the swath width and antenna circles for the Wallops ground station.
Problem Set #1 – Solution
Load a loop of GAC (Global Area Coverage) NOAA-18 images on a Globe Display.  Load visible and low-level water vapor images.  Animate the loop on a rotating globe with a solid blue background image.  
1. Create a globe display and load the data.

a. Remove all layers and data sources.

b. In the Main Display select File -> New Display Tab -> Globe Display -> One Panel.

c. In Data Sources, select <LOCAL-DATA> for Server:, select GAC for Dataset:, click Connect.

d. Choose the GAC N18 area files  Image Type and select a Relative time of 8 most recent.
e. Select Lat/Lon for the Navigation:.

f. Click Add Source to show the Field Selector.

2. Select the 0.63 μm and 12.0 μm bands and display them.
a. Select 0.63 um VIS Cloud and Surface Features -> Brightness.
b. Under Displays click on the Advanced tab.  For Coordinate Type: choose Image Coordinates. Change the Magnification to 1 X 1 with the sliders.  Click on the green arrow icon [image: image4.png]


 to load the full-size image.  For Location: choose Upper Left, and click Create Display.
c. Repeat this process with the 12.0 um IR SFC/Cloud Temp, Low-level WV -> Brightness.

3. Animate the globe and add the background image.  Then analyze and animate the globe display.  
a. Select Display -> Add Background Image.
b. In the Layer Controls in Layer: choose Solid Blue.
c. Start the loop by using the Time Animation buttons at the top of the Main Display.  Turn on the Auto-Rotate view option (View -> Viewpoint from the main display window, or the Auto-Rotate button [image: image5.jpg]


 in the Viewpoint Toolbar to the left of the image).
d. Change the orientation of the globe in the Main Display with the mouse controls.  Restart the Auto rotate view.
Problem Set #2 – Solution

Load a GAC NOAA-18 image.  Display the polar orbit tracks for the image using a two-line element text file with the Polar Orbit Track chooser.  Add the swath width and antenna circles for the Wallops ground station.
1. Display the 19:46:04 UTC NOAA-18 image in a new tab.
a. Remove all layers and data sources.  Click the [image: image6.png]s McDAS-V {12 |
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 in the Main Display to create a new tab.
b. Select <LOCAL-DATA> for Server:, select HRPT for Dataset:, click Connect.
c. Choose the HRPT N18 area files  Image Type and select an Absolute time of 04:45:04 UTC.  

d. Select Lat/Lon for the Navigation:.

e. Click Add Source to show the Field Selector.

f. Select 0.63 um VIS Cloud and Surface Features -> Brightness.
g. Under Displays click on the Advanced tab.  For Coordinate Type: choose Image Coordinates. Change the Magnification to 1 X 1 with the sliders.  Click on the green arrow icon [image: image7.png]


 to load the full-size image.  For Location: choose Upper Left, and click Create Display. 
h. Reproject the display to the continental United States domain.  In the Main Display, select Projections -> Predefined -> US -> CONUS.  Zoom into the image to fill the display.
2. Display the polar orbit tracks from a two-line element file.
a. Select the Under Development -> Imagery – Polar Orbit Track chooser from the Data Sources tab.
b. Click the URL radio button.  Enter the directory path to the two-line element file, noaa18.txt, with the file:/// nomenclature, then click Add Source:
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c. Under Displays click Polar Orbit Track.  In the Time Range tab enter Apr 26, 2012 in both Date: fields.  Then enter 19:30 in Begin Time:, and enter 20:00 in End Time:.  Click Create Display.
d. In the Layer Controls, enter 3000 in Swath Width:. Enter 5 in Font Size:. In Ground Station: click the arrow to show the list of stations, choose Wallops14 (near the top of the list).
Zooming, Panning, and Rotating Controls
	Zooming
	Panning
	Rotating

	
	Mouse
	

	Shift-Left Drag: Select a region by pressing the Shift key and dragging the left mouse button.

Shift-Right Drag: Hold Shift key and drag the right mouse button. Moving up zooms in, moving down zooms out.
	Control-Right Mouse Drag: Hold Control key and drag right mouse to pan.
	Right Mouse Drag: Drag right mouse to rotate.

	
	Scroll Wheel
	

	Scroll Wheel-Up: Zoom Out.

Scroll Wheel-Down: Zoom In.
	
	Control-Scroll Wheel-Up/Down: Rotate clockwise/counter clockwise.

Shift-Scroll Wheel-Up/Down: Rotate forward/backward clockwise.

	
	Arrow Keys
	

	Shift-Up: Zoom In.

Shift-Down: Zoom Out.
	Control-Up arrow: Pan Down.

Control-Down arrow: Pan Up.

Control-Right arrow: Pan Left.

Control-Left arrow: Pan Right.
	Left/Right arrow: Rotate around vertical axis.

Up/Down arrow: Rotate around horizontal axis.

Shift-Left/Right arrow: Rotate Clockwise/Counterclockwise.
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