
McIDAS-V Tutorial 
Using HYDRA to Interrogate Hyperspectral Data 

updated October 2010 (software version 1.0) 
 

 
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation 
in SSEC's 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 
manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 
Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands 
and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being 
integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data. 
 
More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 
McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 
the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 
http://www.ssec.wisc.edu/mcidas/software/v/ .  If you encounter any errors, please send them to the McIDAS 
Help Desk at mug@ssec.wisc.edu . 
 
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 
McIDAS-V.  If you can not start McIDAS-V on your machine, you should follow the instructions in the 
document entitled McIDAS-V Tutorial – Installation and Introduction.   

 
Create a MultiSpectral Display of an AIRS spectra 
 
1. Remove all layers and data sources by selecting Edit ->Remove ->All Layers and Data Sources from the 

main menu. 
 
2. Copy the AIRS.2007.06.19.198.L1B.AIRS_Rad.v5.0.0.0.G07171192741.hdf (60 MB) file to your local 

computer.  This is an AIRS file from 19:47 UTC on June 19, 2007.    
 
3. Load the file into McIDAS-V via the HYDRA chooser by selecting Satellite->HYDRA from the Data 

Sources list in the left panel of the Data Explorer window. 
 

a. Navigate to where the file is located and 
click Add Source. 

 
b. When the file is loaded, the Field Selector 

tab will activate.  Select MultiSpectral 
Display from the Displays list and click 
Create Display. 

 
4. The MultiSpectral Display will be displayed in 

the main window. 
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5. Click on Multi Spectral in the Legend to view the spectra for the AIRS file.  There are four aspects to the 
multispectral display.  

 
a. The first is the image in the Main Display window.   
 
b. The second aspect is the Spectra. The Spectra are displayed in the Display tab in the Layer Controls 

under the "MultiSpectral" Layer. The image displayed upon default is the 919.50 cm-1 spectral region 
(10.8 µm).  

 
c. The final two aspects are the two spectrum probes. In the Main Display, there are two colored square 

boxes that represent the main probe (magenta) and the reference probe (light blue).  The two squares 
may be overlapping, with only the magenta square visible.  Left click+drag either box to view the 
spectra measured in various pixels around the image. 
 

6. Use the Shift+Left Click+Drag combination to zoom in on the satellite image as shown below.   
 
7. To compare the difference in spectra of clear vs. cloudy pixels, move the two probes to the approximate 

locations in the image below so that one is over a thunderstorm cloud top and one is over a dark cloud-free 
pixel. 
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8. Once the two probes are in the approximate locations, the MultiSpectral window should look similar to the 
spectra below.   

 
a. To zoom in on portions of the spectra, use the Control+Left Click+Drag combination to define the 

region of the spectra.   To return to the full spectra, use Shift+Left Click. 
 

 
 
Create a MultiSpectral Display of a MODIS band in McIDAS-V 
 
1. Copy the MYD021KM.A2007170.1950.005.2007171205817.hdf (155 MB) file to your local computer. 
 
2. Remove all layers and data sources by selecting Edit ->Remove ->All Layers and Data Sources from the 

main menu.   
 
3. Load the new file using the same procedure as before, and create a MultiSpectral Display of the 

Emissive_Bands.  
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4. An 11.0 µm image over the Central United States will be displayed from 1950 UTC on June 19, 2007. 
 

 
 
5. To view the spectra, go to the McIDAS-V Main Display window and click on “MultiSpectral” in the 

Legend.  Use the Left Click+Drag option to move the green selector bar or use the Band: drop-down list at 
the bottom of the spectra to switch the band displayed in the Main Display. 
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Create a Scatter Analysis of two bands 
 
1. To make a scatter analysis (plot) of two bands, go to the Data Explorer window and click on the Field 

Selector tab.  If you don’t see the Data Explorer, go to the McIDAS-V Main Display menu and select 
Window -> Show Data Explorer.  In the Field Selector tab, 

 
a. Select the Emissive_Bands field.  This will be the x-axis in your scatter analysis. 
 
b. Select Scatter Analysis for display type in the Displays list.  

 
c. In the lower-right panel, select the Channels tab, and select band 31 (11.0µm). 

 
d. Click Create Display. 

 
2. A second Field Selector will pop up where you can select a field for the second data source to represent the 

y-axis.  In this new Field Selector, 
 

a. Select Reflective_Bands as the second field to use for scatter analysis. 
 
b. Click the Channels tab and select band 1 (0.65 µm). 

 
c. Click OK. 

 

 

 
 



Page 6 of 11 

McIDAS-V Tutorial – Using HYDRA                                                                                         October 2010 – McIDAS-V version 1.0 

3. You should see plots similar to those shown below in the Layer Controls tab.  The plot on the left 
represents the first field selected, the plot in the middle represents the second field, and the plot on the right 
is the scatter analysis of the two fields. The first field selected is represented on the x-axis (abscissa) and the 
second field selected represents the y-axis (ordinate). In this example, it is band 31 (11 µm) versus band 1 
(0.65 µm). 

 

 
 
4. The scatter plot and images can be analyzed by highlighting a box or region in either display.  
 

a. To draw a box, click the “Box” radio button, select one of the three colors to use, and use the Shift+Left 
click and drag option to draw a box over a region of the scatter plot.  The corresponding points in the 
image will be highlighted.  

 
b. Conversely, one can select a region of interest in one of the images and then the corresponding points in 

the scatter plot will be highlighted.   
 

c. To select your own shape, click the “Curve” radio button and use the Left Click and drag option to draw 
an enclosed shape.  Band differences (not shown) can be constructed as a formula and used as one or 
both of the axes for a scatter plot.  
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Problem Sets 
 
The previous examples were intended to give you a general knowledge of how to load and display multi and 
hyperspectral data.  The problem sets below are intended to introduce you to new topics related to the data, as 
well as challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem 
set before looking at the solutions, which are provided below the problem set. 
 
1. Create a Normalized Difference Vegetation Index (NDVI) where NDVI = [Band 2 (0.86µm) – Band 1 (0.65 

µm)]/[ Band 2 (0.86 µm) + Band 1 (0.65 µm)] using the MODIS file.  
 

2. Scatter the Band 31 vs (Band 29 – Band 31).  Make channel 31 the x-axis.  Then, scatter        
Band 31 vs. (Band 32 – Band 31).  Compare the two. 

 
3. Make an online-offline difference of AIRS data. 
 
Problem Set #1 - Solution 
 
1. Remove all Layers. 
 
2. In the Field Selector, select Reflective Bands in the Fields tab and select “4 Channel Combinations” from 

the Displays list and click Create Display. 
 
3. Set up the NDVI equation. 
 

a. Select Band 2 in the red drop down menu.  Note the red selector moves to 0.86µm. 
 
b. To the right of the red drop down menu, select the minus operator from the drop-down list. 

 
c. Select Band 1 in the green drop down menu. 

 
d. To the right of the green drop down menu, select the divide operator from the drop-down list. 

 
e. Select Band 2 in the blue drop down menu. 

 
f. To the right of the blue drop down menu, select the plus operator from the drop-down list. 

 
g. Select Band 1 in the magenta channel box. 

 
h. Click Compute New Field to create a new field of the NDVI. 

 
4. The resulting field will be “(((1.0*a) – (1.0*b))/((1.0*c) + (1.0*d)))” in the Field Selector under the 

“MultiSpectral” field in the Fields list.   
 

a. Click on this new field and select Image Display from the Displays tab. 
 
b. Click Create Display.  To add an NDVI enhancement, go to the Layer Controls.  Click next to Color 

Table:  Choose  Satellite -> GOES -> NDVI. 
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Problem Set #2 – Solution 
 
1. Remove all layers. 

 
2. In the Field Selector, select Emissive Bands in the Fields tab, select “4 Channel Combinations” from the 

Displays list and click Create Display. 
 

3. Create the “Band 29 – Band 31” difference image. 
 

a. Select Band 29 in the red channel box. 
 

b. To the right of the red drop down menu, select the minus operator from the drop-down list. 
 
c. Select Band 31 in the green channel box. 
 
d. Click Compute New Field. 
 

4. Using the same process, create the “Band 31 – Band 32” difference image. 
 

5. Return to the Field Selector to create the Scatter Analysis. 
 

a. Select Emissive Bands in the Fields tab, select “Scatter Analysis” from the Displays list and click 
Create Display.  The default emissive band is band 31.  This will be the x-axis. 

 
b. For the y-axis, select the “Band 29 – Band 31” difference image.  This will be the first “((1.0*a) – 

(1.0*b)) image underneath MultiSpectral in the Fields tab in the Field Selector.  Select the field and 
click OK. 

 
c. The Scatter Display will show up in the Layer Controls tab. 
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6. Repeat these steps to create a scatter analysis display using band 31 as the x-axis and “Band 31 – Band 32” 
as the y-axis. 

 

 
 
7. Undock each scatter display by selecting View->Undock from Data Explorer from the Layer Controls 

menu. 
 
8. Arrange the scatter displays side by side and use the scatter analysis tools to draw boxes and curves on the 

images and scatter plot.  Compare both scatter displays. 
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Problem Set #3 - Solution 
 
1. Remove all layers and data sources, and load the AIRS data file.   
 
2. Return to the Field Selector and select “4 Channel Combinations” from the Displays list and click Create 

Display.   
 
3. Enter in the equation 746.01 (red) – 746.97 (green) and hit Enter.  The vertical red and green lines in the 

spectrum will move to 746.01 cm-1 and 746.97 cm-1, respectively. 
 
4. Zoom in over the region by using the Control+Left Click+Drag option.   
 

 
 

5. Click Compute New Field to create a new field of this online-offline difference.   
 
6. The resulting field will be “((1.0*a) – (1.0*b))” in the Field Selector under the "MultiSpectral" field in the 

Fields list.  Click on this new field and select Image Display from the Displays and click Create Display. 
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The resulting image from the online-offline calculation shows the vertical temperature gradient – in cloudy 
regions (darker), the difference is small because both the online and offline wave numbers detect clouds.  In 
clear regions (lighter), the difference between the two wave numbers is larger, because of the temperature 
gradient through the atmosphere. 
 

 
 

Short Summary of Hydra Controls in McIDAS-V 
Spectra 

Select spectra - write wavenumber in box, select channel from pulldown menu, or middle button click 
Control+Left click+Drag – Select portion of spectra to zoom in on  
Shift+Left click – Return to full spectrum 
Right Click + Drag – Move spectrum right or left  
Middle mouse button (or wheel) click –  Read Brightness Temperatures and Wavenumbers. This will 

provide the value of the Brightness Temperature and Wavenumber at the point on the graph you are 
clicking. It will also move the green line and change the image to that wavenumber. 

Image 
Left Click on a probe and drag – Change pixel that spectra is displaying  
Change band – used spectra window - write wavenumber in box or middle button click 
Move image up or down – use left utility bar arrow icons 
Zoom – Shift+Right Click+Roll over window –or- mouse scroll wheel forward or backward 
Return to Original Image View – Click on house icon in the left utility bar 


